BETA

22nd November 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/11/18 08:57 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [22/11/18 09:15 PM]