BETA

2nd October 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [02/10/19 03:52 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [02/10/19 04:44 PM]