BETA

4th May 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [04/05/17 08:05 AM] with 'Major Outage'

Issue has been resolved at [04/05/17 08:07 AM]