BETA

1st October 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [01/10/19 11:56 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [01/10/19 12:08 PM]