BETA

26th September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [26/09/19 08:58 PM] with 'Partial Outage'

Issue has been resolved at [26/09/19 09:05 PM]