BETA

26th September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [26/09/19 08:58 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/09/19 01:16 PM]