BETA

21st September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [21/09/19 11:58 PM] with 'Major Outage'

Issue has been resolved at [22/09/19 01:04 AM]