BETA

21st September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [21/09/19 11:58 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [26/09/19 08:34 PM]