BETA

21st November 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [21/11/18 05:22 PM] with 'Partial Outage'

Issue has been resolved at [21/11/18 05:24 PM]