BETA

21st November 2018

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [21/11/18 01:27 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [18/12/18 04:07 AM]