BETA

21st September 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [21/09/19 02:19 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [21/09/19 02:59 PM]