BETA

19th September 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [19/09/19 01:28 PM] with 'Major Outage'

Issue has been resolved at [19/09/19 01:31 PM]