BETA

18th September 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [18/09/19 11:28 PM] with 'Partial Outage'

Issue has been resolved at [18/09/19 11:29 PM]