BETA

18th September 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [18/09/19 01:40 PM] with 'Major Outage'

Issue has been resolved at [18/09/19 02:01 PM]