BETA

18th September 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [18/09/19 12:55 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [18/09/19 01:28 PM]