BETA

19th November 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [19/11/18 03:45 PM] with 'Partial Outage'

Issue has been resolved at [19/11/18 03:46 PM]