BETA

16th September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [16/09/19 03:10 PM] with 'Major Outage'

Issue has been resolved at [16/09/19 03:16 PM]