BETA

16th March 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [16/03/19 12:57 AM] with 'Partial Outage'

Issue has been resolved at [16/03/19 12:59 AM]