BETA

16th September 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [16/09/19 01:26 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/09/19 01:34 PM]