BETA

16th September 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [16/09/19 11:56 AM] with 'Major Outage'

Issue has been resolved at [16/09/19 11:58 AM]