BETA

17th November 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [17/11/18 02:57 AM] with 'Partial Outage'

Issue has been resolved at [17/11/18 03:00 AM]