BETA

16th September 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [16/09/19 11:35 AM] with 'Major Outage'

Issue has been resolved at [16/09/19 01:10 PM]