BETA

16th September 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [16/09/19 11:28 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/09/19 12:38 PM]