BETA

16th September 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [16/09/19 05:37 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/09/19 08:13 AM]