BETA

15th September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [15/09/19 03:40 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/09/19 02:50 PM]