BETA

14th November 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [14/11/18 07:06 PM] with 'Major Outage'

Issue has been resolved at [14/11/18 07:35 PM]