BETA

15th September 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [15/09/19 01:16 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/09/19 01:46 PM]