BETA

14th November 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/11/18 12:57 PM] with 'Partial Outage'

Issue has been resolved at [14/11/18 12:58 PM]