BETA

4th May 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [04/05/17 07:54 AM] with 'Major Outage'

Issue has been resolved at [04/05/17 07:55 AM]