BETA

23rd July 2016

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [23/07/16 11:48 AM] with 'Major Outage'

Issue has been resolved at [23/07/16 12:13 PM]