BETA

14th September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/09/19 05:22 PM] with 'Partial Outage'

Issue has been resolved at [14/09/19 05:34 PM]