BETA

14th September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/09/19 02:17 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/09/19 02:34 PM]