BETA

14th September 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [14/09/19 11:17 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/09/19 11:26 AM]