BETA

6th November 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [06/11/18 12:45 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/12/18 12:39 PM]