BETA

5th November 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [05/11/18 01:03 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [05/11/18 02:39 PM]