BETA

13th September 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/09/19 12:08 PM] with 'Major Outage'

Issue has been resolved at [13/09/19 12:12 PM]