BETA

4th November 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [04/11/18 08:05 PM] with 'Partial Outage'

Issue has been resolved at [04/11/18 08:25 PM]