BETA

3rd November 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [03/11/18 02:53 PM] with 'Major Outage'

Issue has been resolved at [03/11/18 02:55 PM]