BETA

12th September 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [12/09/19 05:39 PM] with 'Major Outage'

Issue has been resolved at [12/09/19 05:42 PM]