BETA

3rd November 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [03/11/18 02:58 AM] with 'Partial Outage'

Issue has been resolved at [03/11/18 03:00 AM]