BETA

3rd November 2018

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [03/11/18 02:58 AM] with 'Major Outage'

Issue has been resolved at [03/11/18 03:00 AM]