BETA

3rd November 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [03/11/18 02:57 AM] with 'Partial Outage'

Issue has been resolved at [03/11/18 02:59 AM]