BETA

3rd November 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [03/11/18 02:57 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [05/11/18 01:04 PM]