BETA

12th September 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [12/09/19 11:47 AM] with 'Major Outage'

Issue has been resolved at [12/09/19 12:20 PM]