BETA

2nd November 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [02/11/18 12:01 PM] with 'Partial Outage'

Issue has been resolved at [02/11/18 12:07 PM]