BETA

1st November 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [01/11/18 08:41 PM] with 'Partial Outage'

Issue has been resolved at [01/11/18 08:42 PM]