BETA

31st October 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [31/10/18 09:04 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [31/10/18 09:06 PM]