BETA

16th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [16/03/19 12:42 AM] with 'Partial Outage'

Issue has been resolved at [16/03/19 12:43 AM]