BETA Singapore cluster       Mumbai cluster

9th September 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [09/09/19 05:54 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [09/09/19 06:50 PM]