BETA

31st October 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [31/10/18 02:29 PM] with 'Major Outage'

Issue has been resolved at [31/10/18 02:33 PM]